package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((-?\d+), (-?\d+)\)|\((-?\d+)\)`)
var str = `((3158), (737)) ((3158, 1024), (737))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}