$re = '/\((-?\d+), (-?\d+)\)|\((-?\d+)\)/';
$str = '((3158), (737)) ((3158, 1024), (737))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);