const regex = /\b(?=[a-z]+[A-Z]+|[A-Z]+[a-z]+)[a-zA-Z]{8,20}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?=[a-z]+[A-Z]+|[A-Z]+[a-z]+)[a-zA-Z]{8,20}\\b', 'gm')
const str = `SupercalifragilisticabShdegal abcdefghi jklmnopq RSTuvwxyzasgfsdhs AaAaAaAaA or aaaaaaaaA Zzzzzzzzz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}