$re = '/\b(?=[a-z]+[A-Z]+|[A-Z]+[a-z]+)[a-zA-Z]{8,20}\b/m';
$str = 'SupercalifragilisticabShdegal abcdefghi jklmnopq RSTuvwxyzasgfsdhs AaAaAaAaA or aaaaaaaaA Zzzzzzzzz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);