#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?=.{3,15}$)[A-Za-z0-9]+(?:[_-][A-Za-z0-9]+)*$"
Local $sString = "abcd" & @CRLF & _
"asd" & @CRLF & _
"123456789012345" & @CRLF & _
"a" & @CRLF & _
"as" & @CRLF & _
"aaaaaaaaaaaaaaaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")