using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{3,15}$)[A-Za-z0-9]+(?:[_-][A-Za-z0-9]+)*$";
string input = @"abcd
asd
123456789012345
a
as
aaaaaaaaaaaaaaaa";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}