$re = '/"(GET \/.*?\/.*?,\d+,(\d+)\/.*?)"\s"(\d+)"\s"(\d+)"/';
$str = '124.99.152.202 - naveen [22/Nov/2013:10:41:17 +1300] "GET /p/V4ZkA5d074CTy_vbFa7nLw,1385070078,123/12.txt HTTP/1.1" "200" "3" "-" "Mozilla/5.0" "-"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);