// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""(GET \/.*?\/.*?,\d+,(\d+)\/.*?)"\s"(\d+)"\s"(\d+)""#).unwrap();
let string = "124.99.152.202 - naveen [22/Nov/2013:10:41:17 +1300] \"GET /p/V4ZkA5d074CTy_vbFa7nLw,1385070078,123/12.txt HTTP/1.1\" \"200\" \"3\" \"-\" \"Mozilla/5.0\" \"-\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}