const regex = /^[a-zA-Z]{4,4}-[0-9]{4,4}$/mi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z]{4,4}-[0-9]{4,4}$', 'mi')
const str = `aaaa-1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}