$re = '/^[a-zA-Z]{4,4}-[0-9]{4,4}$/mi';
$str = 'aaaa-1234';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);