re = /^(dw|lat)_([^_]*)_(Paid-Search|Text-Ad)_([^_]*)_([^_]*)_([^_]*)_([^_]*)_([^_]*)_([^_]*)_([^_]*)_([^_]*)$/mi
str = 'lat_march madness update_Paid-Search_subscription-one_google_ncaa-tournament_{adid}_p__March172014_2
lat_los angeles_Paid-Search_nami-media_adn_JgYno0gS7yYjNq8OT7n_LcgTN9nt6vrmbC9qlcp__-21150_49996_7006_April22014_4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end