$re = '/Configure sendmail with the existing \/etc\/mail\/sendmail\.conf\? \[Y\] /m';
$str = 'Configure sendmail with the existing /etc/mail/sendmail.conf? [Y] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);