re = /(?<![)(]),(?![)(])/
str = 'test,test
test),test
test,)test
test),)test
test(,test
test,(test
test(,(test
test(,)test
test),(test
a,c,b, d
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end