$re = '/!!!\s+\K.*?(?=\s+\?{3})/';
$str = 'Image 56 ::: Beach, Summer, Sun !!! John Smith ???';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);