re = /!!!\s+\K.*?(?=\s+\?{3})/
str = 'Image 56 ::: Beach, Summer, Sun !!! John Smith ???'
# Print the match result
str.match(re) do |match|
puts match.to_s
end