import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<lt><)(?:(?!\\/?[[:alnum:]]*>))|(?:\\s[[:alnum:]]*)(?<gt>>)";
final String string = "<tag>text</tag>\n"
+ "<tag2>3 is > than 2</tag2>\n"
+ "<tag3>But 1 in < than 4</tag3>\n"
+ "<tag3>But sometimes we<want or>this</tag3>\n"
+ "<tag3>Or even things like this< < <symbols</tag3>";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}