const regex = /\b(\d+)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+)\\b', 'g')
const str = `12 Voorbeeld3 4Voorbeeld5 6 test 777
Example1 2 33 4test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}