$re = '/\b(\d+)\b/';
$str = '12 Voorbeeld3 4Voorbeeld5 6 test 777
Example1 2 33 4test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);