#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)\{\{\s*Template1\s*(.*?)\n\}\}"
Local $sString = "..." & @CRLF & _
"abas asdn asf asfs af" & @CRLF & _
"{{Template1" & @CRLF & _
"|a = Name surname" & @CRLF & _
"|b = jhsdf sdf" & @CRLF & _
"|c = {{Template2}}" & @CRLF & _
"|d = " & @CRLF & _
"|e = [[f]] and [[g]]" & @CRLF & _
"|h = asd asdasfgasgasg asgas jygh trdx dftf xcth" & @CRLF & _
"|i = 73" & @CRLF & _
"|j = {{Template2|abc|123}}" & @CRLF & _
"|j = {{Template3|aa=kkk|bb={{Template4|cc=uu}}}}" & @CRLF & _
"}}" & @CRLF & _
"" & @CRLF & _
"asd wetd gdsgwew g" & @CRLF & _
"" & @CRLF & _
"{{OtherTemplate" & @CRLF & _
"|sdf = 213" & @CRLF & _
"}}" & @CRLF & _
"..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")