import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{\\s*Template1\\s*(.*?)\\n\\}\\}";
final String string = "...\n"
+ "abas asdn asf asfs af\n"
+ "{{Template1\n"
+ "|a = Name surname\n"
+ "|b = jhsdf sdf\n"
+ "|c = {{Template2}}\n"
+ "|d = \n"
+ "|e = [[f]] and [[g]]\n"
+ "|h = asd asdasfgasgasg asgas jygh trdx dftf xcth\n"
+ "|i = 73\n"
+ "|j = {{Template2|abc|123}}\n"
+ "|j = {{Template3|aa=kkk|bb={{Template4|cc=uu}}}}\n"
+ "}}\n\n"
+ "asd wetd gdsgwew g\n\n"
+ "{{OtherTemplate\n"
+ "|sdf = 213\n"
+ "}}\n"
+ "...";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}