using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(JD[a-zA-Z0-9]{6})(?:,(.*?)(?:,(.*))?)?$";
string input = @"JD231SSD, First Name, Last Name
JD231SSD, First Name
JD231SSD";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}