package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(JD[a-zA-Z0-9]{6})(?:,(.*?)(?:,(.*))?)?$`)
var str = `JD231SSD, First Name, Last Name
JD231SSD, First Name
JD231SSD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}