using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CL_\S+(?:\s*(?!CL_)\S+)";
string input = @"CL_6x CL_5c CL_234 CL_ERB14 1D CL_6y";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}