const regex = /CL_\S+(?:\s*(?!CL_)\S+)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('CL_\\S+(?:\\s*(?!CL_)\\S+)', 'gim')
const str = `CL_6x CL_5c CL_234 CL_ERB14 1D CL_6y`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}