package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\b[0-9|.]{1,10}\-[K|k|0-9]`)
var str = `16475594-0
16.475.594-0
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}