$re = '/\b[0-9|.]{1,10}\-[K|k|0-9]/mi';
$str = '16475594-0
16.475.594-0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);