package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(X|IX|IV|VI{0,3}|I{1,3}) ?[+/*-] ?(X|IX|IV|VI{0,3}|I{1,3})$`)
var str = `III //false
III +
III + X
I + I
II + II
III + III
IIII + IIII
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}