re = /^(X|IX|IV|VI{0,3}|I{1,3}) ?[+\/*-] ?(X|IX|IV|VI{0,3}|I{1,3})$/m
str = 'III //false
III +
III + X
I + I
II + II
III + III
IIII + IIII
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end