use strict;
my $str = 'U:\\16. New Products\\#Complete\\Bottle Openers\\20170210 St Patrick Bottle Openers\\Small Lifestyles
U:\\16. New Products\\#Complete\\Canvas
U:\\16. New Products';
my $regex = qr/^(([^\\]+)\\([^\\]+)){1,4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}