$re = '/^(([^\\\\]+)\\\\([^\\\\]+)){1,4}$/m';
$str = 'U:\\16. New Products\\#Complete\\Bottle Openers\\20170210 St Patrick Bottle Openers\\Small Lifestyles
U:\\16. New Products\\#Complete\\Canvas
U:\\16. New Products';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);