import re
regex = re.compile(r"\[[^#]*#\K\d{1,16}", flags=re.MULTILINE)
test_str = ("I made a commit [#12345678] to a story\n"
"[finished #12345678] Made a commit\n"
"[fixed #12345678] Made a commit\n"
"[complete #12345678] Made a commit")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")