const regex = /\[(?:fi(?:x|nish)ed ?|complete ?)?#\K\d{1,16}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(?:fi(?:x|nish)ed ?|complete ?)?#\\K\\d{1,16}', 'gm')
const str = `I made a commit [#12345678] to a story
[finished #12345678] Made a commit
[fixed #12345678] Made a commit
[complete #12345678] Made a commit`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}