re = /\[(?:fi(?:x|nish)ed ?|complete ?)?#\K\d{1,16}/m
str = 'I made a commit [#12345678] to a story
[finished #12345678] Made a commit
[fixed #12345678] Made a commit
[complete #12345678] Made a commit'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end