package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(.*?)(?:\.styled))?(.*)$`)
var str = `file-name.here
file-name.styled.here`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}