re = /^(?:(.*?)(?:\.styled))?(.*)$/m
str = 'file-name.here
file-name.styled.here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end