import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{8,15}$)(?=.*[A-Za-z])(?=.*\\d)(?!.*?(.)\\1{3})[A-Za-z0-9]+$";
final String string = "abcdedsnnsd\n"
+ "abcdedddddd\n"
+ "abxj12256765762";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}