const regex = /\B(?=(?:\d{2})*\d{3}(?!\d|[^.]))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B(?=(?:\\d{2})*\\d{3}(?!\\d|[^.]))', 'g')
const str = `32423332.343
129846`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}