$re = '/\B(?=(?:\d{2})*\d{3}(?!\d|[^.]))/';
$str = '32423332.343
129846';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);