import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "PLCMPLD00016.html\">(.*?)<\\/a>|\"ar\">(.*?)<\\/td> ";
final String string = "<a class=\"link\" href=\"http://www.money.pl/gielda/spolki-gpw/PLCMPLD00016.html\">SYGNITY</a>\n\n"
+ " </td>\n"
+ " <td class=\"ac\"><a href=\"javascript: OO('SGN','2015-10-01')\"><img width=\"12\" height=\"11\" src=\"http://static1.money.pl/i/gielda/chart.gif\" title=\"Pokaż wykres\" alt=\"Pokaż wykres\" /></a></td>\n"
+ " <td class=\"al\">SGN</td>\n"
+ " <td class=\"ar\">8,40</td> ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}