$re = '/PLCMPLD00016.html">(.*?)<\/a>|"ar">(.*?)<\/td> /';
$str = '<a class="link" href="http://www.money.pl/gielda/spolki-gpw/PLCMPLD00016.html">SYGNITY</a>
</td>
<td class="ac"><a href="javascript: OO(\'SGN\',\'2015-10-01\')"><img width="12" height="11" src="http://static1.money.pl/i/gielda/chart.gif" title="Pokaż wykres" alt="Pokaż wykres" /></a></td>
<td class="al">SGN</td>
<td class="ar">8,40</td> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);