re = /^(\d+(-\d+)?,\s*)*(\d+(-\d+)?\s*)$/m
str = '10-12, 6, 50-56
12
12-12
12-6, 2
12-6, 2-2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end