// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+(-\d+)?,\s*)*(\d+(-\d+)?\s*)$").unwrap();
let string = "10-12, 6, 50-56
12
12-12
12-6, 2
12-6, 2-2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}