using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Air.*\s(\d+\.\d)F";
string input = @"24 Jul 2013: Water - 74.0F / 23.3C; Air - 68.0F / 20.0C. John L. helped out a wounded cyclist; Anthony C. swam 1km";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}