// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Air.*\s(\d+\.\d)F").unwrap();
let string = "24 Jul 2013: Water - 74.0F / 23.3C; Air - 68.0F / 20.0C. John L. helped out a wounded cyclist; Anthony C. swam 1km";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}