package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+(?:\s\|\s\w+)*$`)
var str = `Hello | There | Yes
hello|There
456 | 654 | 645 | 465`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}