re = /^\w+(?:\s\|\s\w+)*$/m
str = 'Hello | There | Yes
hello|There
456 | 654 | 645 | 465'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end