#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:4[0-9]{2}|5[0-4][0-9]|550)\b"
Local $sString = "400" & @CRLF & _
"401" & @CRLF & _
"390" & @CRLF & _
"501" & @CRLF & _
"550" & @CRLF & _
"549" & @CRLF & _
"551"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")