$re = '/\b(?:4[0-9]{2}|5[0-4][0-9]|550)\b/';
$str = '400
401
390
501
550
549
551';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);