$re = '/^.*(?<!subscription)\/status$/m';
$str = 'Some subscription/status
Some/status
/status';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);