re = /^.*(?<!subscription)\/status$/m
str = 'Some subscription/status
Some/status
/status'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end